How to update TB Sirate Starter?

+1
-1
-1

Any website using version 7.x-1.0-beta3 is showing a prompt that 7.x-1.0-beta5 is now available. When we go to the "Update" tab however, the update fails consistently.

Can you tell us the correct way to update a running site that is using TB Sirate Starter as its parent theme?

Thanks,
Jasper

+1
-1
-1

Hi jasperlevi,

TB Sirate Starter is a distribution which includes Drupal core, themes, modules and database to build a new site like our TB Sirate demo easily. Therefore, any version of TB Sirate Starter will not work with existing sites. A lot of the new modules developed can be installed separately (ex: TB Mega Menu), but you will break your site if you try to install this distribution on your current site. Moreover, any TB Starter has the same issue "Undefined index: drupal in update_requirements()", you should take a look at this post to know how to solve it.

+1
-1
-1

Hi,

I am not installing this distribution on an existing site. I started a site project using this distribution. A month into development i am getting this update message, and the site won't update. While i understand that Drupal core updates are not possible, the theme and/or modules should update, right? Why is that not happening? Could I update the site by placing the updated theme and modules into my installation, or do I not start any site using your "Starter" themes? Let me know...

+1
-1
-1

Hi jasperlevi,

The issue "Undefined index: drupal in update_requirements()" makes Update Manager of Drupal core does not work properly. You should solve this issue first before updating themes, and modules of your site. Moreover, you could manually update by placing the updated themes and modules into your site.