How to get CKEditor to display line breaks?


Hello -
I've tried a few combination but never managed to get CKEditor to actually display line breaks, regardless of the number of CR I do.

All text comes in one single line.

I am clueless.

No answers yet


Any live site to re-produce the issue?

Hi epollux,

looks like there is a conflict in CSS. But I am not sure, can you please share with us a URL where we can see what issue you are facing? At the moment we don't support or work with any WYSIWYG editor as we want to avoid those problems you are having.

I can give it a try to check where the problem is, but keep in mind that CKEditor is a 3rd party module and we don't support it. If I don't find a solution quick, please ask for support from the CKEditor team. Please understand that.


Hi. It's only on my local

Hi. It's only on my local machine. I was asking because I did install the drupal package you included with the template and it included CKEditor - so I wondered if you had the issue before. No worries I will try to find out and post an answer here if I troubleshoot it.

Hi eppollux,

Hi eppollux,

my bad. We have packed unused modules in the our installation profile, we will remove them to avoid confusion like this. Thanks for your understanding and really looking for your trouble shoot solution! Would help others here as well!


It works with TinyMCE BUT with TinyMCE I can't get the formatting options to appear in the tool bar ! :-)